"Gradle Version 2.10 is required." Error


As I've been using

classpath 'com.android.tools.build:gradle:+'

In the build.gradle file, I got the following error since gradle version 2.10 has been released. The error is :

Warning:Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in C:\Users\blahblah\myproject\gradle\wrapper\gradle-wrapper.properties to gradle-2.10-all.zip

at first it looks easy to solve by the guide, but when I'd done the change, I got the error again.

I'm using Android Studio 2.0 with the latest Android SDK Tools 24.4.1 and Android SDK Build Tools 23.0.2

I've even tried to download Gradle 2.10 and put it manually on android-studio\gradle\ folder, but no luck.

Any help would be appreciated.

This question is tagged with android android-studio plugins gradle android-gradle-plugin

~ Asked on 2016-01-15 15:24:36

The Best Answer is


You need to change File > Settings > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home path

On Mac OS, change the path in Android Studio > Preferences > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home

Or set Use default gradle wrapper and edit Project\gradle\wrapper\gradle-wrapper.properties files field distributionUrl like this


~ Answered on 2016-01-15 15:32:47


Open Preference and search for Gradle or Navigate to Builds, Execution, Deployment > Build Tools > Gradle

Then change Project-Level setting to Use default gradle wrapper (recommended)

Or keep local gradle distribution option and set Gradle home to /.../gradle-2.10

Preference screen - Gradle

Make Sure that Gradle version is already setup to 2.10 in Module Settings

On the Project Window, right click on your project then select Open Module Settings (?+?)

Open Module Settings Project > Gradle version and enter 2.10


Gradle Version: 3.3 Android Plugin version: 2.3.1

~ Answered on 2016-01-27 17:17:46

Most Viewed Questions: