Android Studio - Failed to notify project evaluation listener error

94

Following is the build.gradle code in Android Studio

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "com.sg.blahblah"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }

    lintOptions {
        checkReleaseBuilds true
        abortOnError false
        xmlReport true
        htmlReport true
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'

            lintOptions {
                disable 'MissingTranslation'
            }
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.1.1'
    compile 'com.android.support:design:23.1.1'
    compile 'com.android.support:support-v4:23.1.1'
    compile 'com.android.support:cardview-v7:23.1.1'
    compile 'com.google.android.apps.dashclock:dashclock-api:+'
    compile 'com.roughike:bottom-bar:1.4.0.1'
    compile 'com.diogobernardino:williamchart:2.2'
}

I am getting the below error: Error:A problem occurred configuring project ':app'.

Failed to notify project evaluation listener. com.android.build.gradle.tasks.factory.AndroidJavaCompile.setDependencyCacheDir(Ljava/io/File;)V

Can anyone please help?

Following is the Instant Run screenshot enter image description here

This question is tagged with android android-studio build.gradle

~ Asked on 2017-05-21 06:57:29

The Best Answer is


37

I am facing same error before a week I solve by disabling the Instant Run

File ? Settings ? Build, Execution, Deployment ? Instant Run and uncheck Enable Instant Run.

Hope it works.

Note This answer works on below Android Studio 3

~ Answered on 2017-05-21 07:05:06


64

I got this problem too. I fix it by Change build.gradle in project

Change

dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'
}

And also I change the distributionUrl in gradle-wrapper.properties(Global Version)

distributionUrl=https\://services.gradle.org/distributions/gradle-4.0-milestone-1-all.zip

And got succeed.FYI.

~ Answered on 2017-06-21 02:09:49


Most Viewed Questions: