Enabling the OpenSSL in XAMPP

48

I spent three hours but I did not find anything; I'm unable to connect to a SSL enabled server. I want to list what i did:

First checked my PHP extensions directory was in order; extension wasn't there, php_openssl.dll

Then I opened my php.ini file but I could not see any extension=php_openssl.dll line to uncomment.

Also, I searched on Google and saw people with the same problem. http://www.apachefriends.org/f/viewtopic.php?p=162623

However, I also have

OPENSSL_CONF C:/xampp/apache/bin/openssl.cnf 
...
openssl
OpenSSL support enabled 
OpenSSL Library Version OpenSSL 0.9.8l 5 Nov 2009 
OpenSSL Header Version OpenSSL 0.9.8l 5 Nov 2009

no lines . What should I do? Please share your suggestions.

This question is tagged with php ssl xampp

~ Asked on 2012-02-27 13:49:47

The Best Answer is


104

Yes, you must open php.ini and remove the semicolon to:

;extension=php_openssl.dll

If you don't have that line, check that you have the file (In my PC is on D:\xampp\php\ext) and add this to php.ini in the "Dynamic Extensions" section:

extension=php_openssl.dll

~ Answered on 2012-06-14 20:00:10


9

[PHP_OPENSSL]
extension=php_openssl.dll

This is the answer.

~ Answered on 2012-02-28 08:54:04


Most Viewed Questions: