I think the most important thing to keep in mind is: is the name descriptive enough? Can you tell by looking at the name what the Class is supposed to do? Using words like "Manager", "Service" or "Handler" in your class names can be considered too generic, but since a lot of programmers use them it also helps understanding what the class is for.
I myself have been using the facade-pattern a lot (at least, I think that's what it is called). I could have a User
class that describes just one user, and a Users
class that keeps track of my "collection of users". I don't call the class a UserManager
because I don't like managers in real-life and I don't want to be reminded of them :) Simply using the plural form helps me understand what the class does.