Linux configure/make, --prefix?

45

Bear with me, this one's not very easy to explain...

I'm trying to configure, make and make install Xfce into my buildroot build directory. When configuring I'm using

--prefix=/home/me/somefolder/mybuild/output/target

so that it builds to the right folder, however when it's compressed and run I get errors from various config files where it's looking for files in

/home/me/somefolder/mybuild/output/target

(which of course doesn't exist.)

How do I set what folder to build into, yet set a different root directory for the config files to use?

This question is tagged with linux build makefile configure prefix

~ Asked on 2012-01-17 22:38:49

The Best Answer is


57

Do configure --help and see what other options are available.

It is very common to provide different options to override different locations. By standard, --prefix overrides all of them, so you need to override config location after specifying the prefix. This course of actions usually works for every automake-based project.

The worse case scenario is when you need to modify the configure script, or even worse, generated makefiles and config.h headers. But yeah, for Xfce you can try something like this:

./configure --prefix=/home/me/somefolder/mybuild/output/target --sysconfdir=/etc 

I believe that should do it.

~ Answered on 2012-01-17 22:48:14


0

In my situation, --prefix= failed to update the path correctly under some warnings or failures. please see the below link for the answer. https://stackoverflow.com/a/50208379/1283198

~ Answered on 2018-05-07 06:48:49


Most Viewed Questions: