How to fix 'Microsoft Excel cannot open or save any more documents'

25

I am running C# ASP.NET 4.5 web application on Windows 7 64-bit using IIS 7.5. The application pool it uses has the name 'ASP.NET v4.0' and its identity is ApplicationPoolIdentity. The application uses MS Office Interop (Microsoft Excel 14.0 Object Library).

At line wBook = wBooks.Add(Missing.Value);, it throws the following error:

Microsoft Excel cannot open or save any more documents because there is not enough available memory or disk space.

u2022 To make more memory available, close workbooks or programs you no longer need.

u2022 To free disk space, delete files you no longer need from the disk you are saving to.: at Microsoft.Office.Interop.Excel.Workbooks.Add(Object Template)

1) I gave the account IIS apppool\ASP.NET v4.0 full control on MS Excel Application in DCOM Config.

2) I gave IIS apppool\ASP.NET v4.0 full control on 'C:\Windows\SysWOW64\config\systemprofile' and created a Desktop folder in it.

3) I need to continue using Interop though it's not recommended.

4) The application works fine on Windows Server 2003/Windows XP 32-bit.

5) MS Office 2010 (64-bit, trial version) is installed on the machine.

6) I would prefer not to change the app. pool identity from ApplicationPoolIdentity to Network Service etc.. ApplicationPoolIdentity is the new type of Identity in IIS 7 and it's recommended.

It works fine if I select 'Interactive User' (I have logged in as an admin) in DCOM Config, but it causes other problems. I need to use 'Launching User' which is ASP.NET v4.0. So it looks like it's a permission issue.

Please help. Thank you.

This question is tagged with iis-7 asp.net-4.0 office-interop windows-7-x64 excel-interop

~ Asked on 2012-09-13 22:29:30

The Best Answer is


41

Right click on the file with file explorer, choose Properties, then General tab and click on the Unblock button. This error message is very misleading.

~ Answered on 2013-07-05 18:40:26


16

Go to this key on Registry Editor (Run | Regedit) HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

change key Cache to something like C:\Windows\Temp

My similar problem was solved like this.

Regards,

Ripley

~ Answered on 2013-04-22 22:08:41


Most Viewed Questions: