[visual-studio-2010] Text overwrite in visual studio 2010

Really silly problem here.

In Visual Studio 2010, the text cursor has changed from the blinking line, to a blinking grey box around the characters. When I type overwrites the text in front of it.

I'm not sure how to get this off? It's like what happens when you press the insert key in microsoft word and overwrite mode gets turned on.

I'm working on a mac with a windows virtual machine so when I hit insert it's just a shortcut key for Parallels (the Virtual Machine program I'm running).

Would appreciate any help!!

This question is related to visual-studio-2010

The answer is


If pressing the Insert key doesn't work, try doubleclicking the INS/OVR label in the lower right corner of Visual Studio.


I'm using Visual Studio with Parallels/Win 7 on a MacBook laptop keyboard and the only thing that worked was Fn + Enter/Return (that's the Mac shortcut for Insert).


Ran into this issue with Parallels and VS 2013. Command + Insert also fixed it in my setup, in addition to the accepted answer. On my Windows USB keyboard Command == WindowsKey.


None of the solutions above were working for me. My workaround was to open the on-screen keyboard using the system settings (press Windows key and search for "keyboard" to find them). Once that's open you can click the Insert key on it.


press your keyboard Insert Key


I am using Visual Studio 2013 and Win 8.1. It was Shift + 0 (0 is my insert key) on the number pad of my laptop.


If you don't have an insert key, and you're using Visual Studio 2019, then double-clicking the OVR text in the bottom right corner does not work. You'll have to use an on-screen keyboard, if you have one of those, or figure out what your insert key is mapped to. For me, on my mac keyboard hooked up to windows 10, it is the 0 key on the keypad.


I'm using Visual Studio 2019. I used the shortcut below:

Shift + Insert


Visual Studio : Right Bottom : Look for OVR label. Double Click on it.

Bingo...