java.lang.UnsupportedClassVersionError Unsupported major.minor version 51.0

The Solution to java.lang.UnsupportedClassVersionError Unsupported major.minor version 51.0 is


These guys gave you the reason why is failing but not how to solve it. This problem may appear even if you have a jdk which matches JVM which you are trying it into.

Project -> Properties -> Java Compiler

Enable project specific settings.

Then select Compiler Compliance Level to 1.6 or 1.5, build and test your app.

Now, it should be fine.

~ Answered on 2012-06-29 15:43:47


Most Viewed Questions: