Settings to Windows Firewall to allow Docker for Windows to share drive


Windows Firewall is blocking my attempt to allows Docker for Windows to share C: on windows 10 machine.

Works fine when Windows Firewall off. When its on I get

A firewall is blocking file Sharing between Windows and the containers. See documentation for more info.

The documentation says

You do not need to open port 445 on any other network. By default, allow connections to port 445 (the Windows host) from (the virtual machine).

I am "googled out" on trying to find how to do that - can someone advise?

This question is tagged with docker docker-for-windows

~ Asked on 2017-02-13 11:58:04

The Best Answer is


You don't actually need to share the C drive but only reinstall (or potentially even uncheck - click OK - then check) the File and Print sharing service on the Hyper-V virtual network card. See this article.

Also if there are restrictions on your network profiles (i.e. public), consider changing the default "unidentified network" for the "vEthernet (DockerNAT)" card to private via this PowerShell command before doing the above:

Set-NetConnectionProfile -interfacealias "vEthernet (DockerNAT)" -NetworkCategory Private

~ Answered on 2017-05-10 23:11:22


Ok, so after running in the same issue, I have found a Solution.

This is what I did:

Step 1: Open ESET. Then click on Setup

click setup

Step 2: Click on Network protection

click network protection

Step 3: Click on Troubleshooting wizard

click troubleshooting wizard

Step 4: Find the Communication (Default docker IP setting) Just check what the IP Range is defined inside your docker settings. Then look for for the IP which resides in that range.

find the connection

Step 5: Click on the Unblock button, then you should receive this screen.

click unblock

This solved the issue for myself.

You can then go to the Rules and check the rule that was added.

PS: This is my first post, sorry for any incorrect procedures.

~ Answered on 2017-03-22 15:05:04

Most Viewed Questions: