[java] intelliJ IDEA 13 error: please select Android SDK

I have installed Android SDK 22.3 and JDK 1.7 update 21 on Win7 x64. Now I created an empty android application project using intelliJ 13.0.1 (also use Emulator as target device) and tried to build the project, but encountered the 'Error: Please select Android SDK'.

So I choose Emulator as the Target Device, but I could not select my AVD, as there is a Error: Cannot find any configured Android SDK.

In the Project Structure, it clearly shows 'Android 4.4.2 platform' as Project SDK. So I am totally confused, don't know how to resolve the issue.

ps. I was upgrading intelliJ 12.1.2 to intelliJ 13.0.1, and all the settings were automatically inherited from 12.1.2 when launching 13.0.1, but it seems not all the settings were exactly copied over to 13.0.1, which is unexpected.

cheers

This question is related to java android intellij-idea

The answer is


Delete all android SDKs from Intellij and add them again.

To do this open project structure, in SDK pane, delete all android SDK, click OK. open project structure and add them again.


Check next lines in you app build.gradle file.

android {
    compileSdkVersion 25       <--- Set exist in local machine sdk version.
    buildToolsVersion '25.0.3' <--- Set exist build tools version.
}

I had same problem once. every things seems right. I restart, delete and invalidate cache of Android studio, rebuild, clean and nothings changed. It is finally solved by click on Sync Project with Gradle Files button in android studio 3.0

Sync Project with Gradle Files button


I encountered this error after installing Intellij IDEA Ultimate 14.1 and opening an existing Android project I had created using Android Studio. It turns out I just had to add the Android SDK to my list of SDKs and fix the project/module SDK settings. This is how I did it:

Go to File -> Project Structure. Click on the Project tab under Project Settings. Under Project SDK click on New -> Android SDK.

Adding new Android SDK

Now select the existing directory for your Android SDK. In my case it was in this folder:

C:\Users\<windows username>\AppData\Local\Android\android-sdk

Click Ok. A menu pops up asking you to set the Java SDK + Build target. You can either change these or leave it as its defaults and hit Ok. You should now see "Android API XX Platform" in the Project SDK dropdown. Click apply on the bottom. Then go to the Modules tab under Project Settings and click on the folders in the modules listing.

Module List

For each folder go to the dependencies tab and change the Module SDK to the new Android SDK and click apply. Then click Ok to close the Project Structure dialog.

After doing the above, my project was fixed.


I had the same problem as you did when I also updated from intellij Idea 12 to 13. In my situation, my Android SDK's Build target wasn't recognized properly, it said something like "Not set" in red instead Android 2.2. Even though I chose Android 2.2 and clicked apply and OK, it showed the "Not set" message again when I reopened the project structure dialog.

Then I chose an other version, Android 4.0 this time, clicked apply, then chose Android 2.2 again, clicked apply. This worked for me.


I have same problem once.I solved this by File->Open->other project,then switch this project by this way.


My Problem: "please select Android SDK", But everything is okey :( -> I think one of IntelliJ file was crashed (after blue screen of death)

My resolution:

File -> Settings -> Android SDK -> Android SDK Location Edit -> Next, Next (Android SDK is up to date.), Finished

... and crashed file was repaired!


there is a button by name android monitor on the left bottom of the screen. if u have an issue with sdk it will show u confugure link.Change the path to your sdk folder. things will work


I faced the problem in IntelliJ Idea 14 actually. My project was working fine on Android Studio. I decided to continue development on IntelliJ idea. After import of project, I wasn't successful to RUN it and I got similar error message in Edit Configuration box. Based on What @Ali said, I deleted all my SDKs and reinstalled them again but didn't work.

I opened "Project Structure">"Platform Settings">SDKs. I found "Build target" of "Android API 21 Platform" is not set. By set it to one of my latest SDK the problem fixed and I could run project without problem.


I had a similar problem. I had to add the same android sdk that i used before again and it worked.


Maybe not so common solution but for me restarting the IDE worked just fine. I use Android Studio 2.2.3.


Seems a lot like IDEA can't find the Android SDK.

Have restarted the computer after using the Android SDK Installer?

After that, have you started the SDK Manager to install the Android 4.2.2 SDK?

Can you check the Android_SDK_HOME environment variable?


Take into account that the Android SDK Installer just installs a Manager. After that, you have to install an SDK (or several).

Also, when you see 'Android 4.4.2 platform' in the Project Structure, that means that the project will ask for that SDK. It doesn't mean that the SDK has been installed.


If you can't compile a proyect and you have this message:

enter image description here

Go to File -> Project Structure, then go to Modules section and select your module app and then select a Compile Sdk Version and a Build Tools Version after that click in OK.

enter image description here

Wait until gradle synchronize and ready!


File -> Invalidate Caches / Restart did the trick for me (which is always a good first try)


in android 3.1.1 we cant find sync project in tools so C:\Users\AndroidStudioProjects\projectname\.idea\libraries remove the files from libraries and sync again


You have to Select Build Tool Version from your project setting.

  1. Select Project App Folder
  2. Press F4 OR Right Click on Project App Folder and open Module Settings In The Properties tab select Build Tool Version from List

This will work on my side i hope it will help you.


check if you have installed all the add-ons that are necessary. Also I recommend you to use a real android phone for debugging. It's better, It's real and faster.


  1. Go to Project structure (Ctrl + Alt + shift + S) -> Platforn settings -> SDKs -> press "Plus" icon
  2. Select "Android SDK" and input the SDKs path (for exanple: C:\Program Files (x86)\Android\android-sdk)
  3. Apply or OK button
  4. Be happy

Examples related to java

Under what circumstances can I call findViewById with an Options Menu / Action Bar item? How much should a function trust another function How to implement a simple scenario the OO way Two constructors How do I get some variable from another class in Java? this in equals method How to split a string in two and store it in a field How to do perspective fixing? String index out of range: 4 My eclipse won't open, i download the bundle pack it keeps saying error log

Examples related to android

Under what circumstances can I call findViewById with an Options Menu / Action Bar item? How to implement a simple scenario the OO way My eclipse won't open, i download the bundle pack it keeps saying error log getting " (1) no such column: _id10 " error java doesn't run if structure inside of onclick listener Cannot retrieve string(s) from preferences (settings) strange error in my Animation Drawable how to put image in a bundle and pass it to another activity FragmentActivity to Fragment A failure occurred while executing com.android.build.gradle.internal.tasks

Examples related to intellij-idea

IntelliJ: Error:java: error: release version 5 not supported Has been compiled by a more recent version of the Java Runtime (class file version 57.0) Error: Java: invalid target release: 11 - IntelliJ IDEA IntelliJ can't recognize JavaFX 11 with OpenJDK 11 Error: JavaFX runtime components are missing, and are required to run this application with JDK 11 ERROR Source option 1.5 is no longer supported. Use 1.6 or later Cannot inline bytecode built with JVM target 1.8 into bytecode that is being built with JVM target 1.6 How to configure "Shorten command line" method for whole project in IntelliJ intellij idea - Error: java: invalid source release 1.9 Failed to resolve: com.google.android.gms:play-services in IntelliJ Idea with gradle